Failed to create shadow copy on Linux while launching through Mono

Added by Sameer Chandragiri about 5 years ago

I installed CruiseControl 1.6.7981.1 on Red Hat Linux 6 along with Mono.

When I run CCNET through Mono, I get the below trace. Would anybody please help on how to solve this? I have looked around for answers but found nothing that solved this issue.
Thanks!

.
.
2012-12-14 16:23:31,917 [CCNet Server] [INFO] - Reading configuration file "/opt/ccnet/bin/ccnet.config"
2012-12-14 16:23:31,945 [CCNet Server] [ERROR] - INTERNAL ERROR: Failed to create shadow copy (CopyFile).
----------
System.ExecutionEngineException: Failed to create shadow copy (CopyFile).
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.PreprocessorEnvironment.EvalTextSymbols (System.String input) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessTextNode (System.Xml.Linq.XText node) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor.Process (System.Xml.Linq.XNode node) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessNonPpElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor.Process (System.Xml.Linq.XNode node) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessNonPpElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor.Process (System.Xml.Linq.XNode node) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessNonPpElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor.Process (System.Xml.Linq.XNode node) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessNonPpElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor._ProcessElement (System.Xml.Linq.XElement element) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ElementProcessors.DefaultProcessor.Process (System.Xml.Linq.XNode node) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ConfigPreprocessor.<PreProcess>b__1 (System.Xml.Linq.XNode node) [0x00000] in <filename unknown>:0
at System.Linq.Enumerable+<CreateSelectManyIterator>c__Iterator12`2[System.Xml.Linq.XNode,System.Xml.Linq.XNode].MoveNext () [0x00000] in <filename unknown>:0
at System.Linq.Enumerable+<CreateWhereIterator>c__Iterator1D`1[System.Xml.Linq.XNode].MoveNext () [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.Preprocessor.ConfigPreprocessor.PreProcess (System.Xml.XmlReader input, System.Xml.XmlWriter output, System.Xml.XmlUrlResolver resolver, System.Uri inputUri) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.DefaultConfigurationFileLoader.CreateXmlValidatingLoader (System.IO.FileInfo configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.DefaultConfigurationFileLoader.AttemptLoadConfiguration (System.IO.FileInfo configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.DefaultConfigurationFileLoader.LoadConfiguration (System.IO.FileInfo configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.DefaultConfigurationFileLoader.Load (System.IO.FileInfo configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.FileConfigurationService.Load () [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.FileWatcherConfigurationService.Load () [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.Config.CachingConfigurationService.Load () [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.CruiseServer..ctor (IConfigurationService configurationService, IProjectIntegratorListFactory projectIntegratorListFactory, IProjectSerializer projectSerializer, IProjectStateManager stateManager, IFileSystem fileSystem, IExecutionEnvironment executionEnvironment, System.Collections.Generic.List`1 extensionList) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.CruiseServerFactory.CreateLocal (System.String configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.CruiseServerFactory.CreateRemote (System.String configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.CruiseServerFactory.Create (Boolean remote, System.String configFile) [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.ConsoleRunner.LaunchServer () [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Core.ConsoleRunner.Run () [0x00000] in <filename unknown>:0
at ThoughtWorks.CruiseControl.Console.AppRunner.Run (System.String[] args, Boolean usesShadowCopying) [0x00000] in <filename unknown>:0


Replies (1)

RE: Failed to create shadow copy on Linux while launching through Mono - Added by Daniel Nauck almost 5 years ago

As far as i know the preprocessor is not compatible with Mono.

It would be nice if you open an issue for that.

(1-1/1)