[Encrypt communications] An item with the same key has already been added. (Bug #204)


Added by Rezgar Cadro over 4 years ago. Updated about 3 years ago.


Status:Closed Start date:09/28/2012
Priority:High Due date:
Assignee:- % Done:

0%

Category:- Spent time: -
Target version:1.8.5
Affected version:1.8.2

Description

When trying to check "Encrypt communications" the following issue occurrs: first time CCTray connects to CCNet server just fine, project list is available. When CCTray application is closed and reopened the connection is not available. When trying to delete the old record and add it once more you recieve an error message:

Failed to connect to server: Server did not allow the connection to be secured: Unable to process: An item with the same key has already been added.

CCTray version: 1.8.2
Windows Server 2008, SP2

PS: Could not post the issue in CCTray bug-tracker since Affected Version can not be selected there.


cctray-failed-to-connect.png (24.3 kB) Rezgar Cadro, 09/28/2012 02:13 pm


History

Updated by Ruben Willems over 4 years ago

  • Target version deleted (1.8.3)

Updated by Mark Vinten over 4 years ago

I found that this was caused by the server service itself.

Steps to reproduce:
1. Goto Settings and Add server to CCTray using Encrypt Communications
2. Add projects and click ok
3. Goto Settings, Remove all projects from above server and click ok (this removes the server from CCTray)
4. Try to repeat step 1 and it fails.

Restarting the CruiseControl.NET server service fixes the issue.

Updated by @ beck about 4 years ago

this is still an issue with CC.TRAY 1.8.3, and CC server 1.8.3

Updated by Ruben Willems almost 4 years ago

  • Target version set to 1.8.5

Updated by @ beck over 3 years ago

potential fix submitted as pull request - https://github.com/ccnet/CruiseControl.NET/pull/207/files

Updated by Ruben Willems about 3 years ago

  • Status changed from New to Closed

Also available in: Atom PDF