Add configuration to control Label merge/replace on VSTS/TFS source control (Feature #216)


Added by Aldus Monitor over 4 years ago. Updated over 2 years ago.


Status:Rejected Start date:10/15/2012
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Configuration Spent time: -
Target version:1.9

Description

Add configuration to control Label merge/replace/exception on VSTS/TFS source control. Need 3 options:
<ApplyLabelControl>Exception(Default)</ApplyLabelControl>
<ApplyLabelControl>Merge</ApplyLabelControl>
<ApplyLabelControl>Replace</ApplyLabelControl>

To avoid this error:

ThoughtWorks.CruiseControl.Core.CruiseControlException: Ignoring the /server option.
TF14076: Cannot create the label {label} because it has child labels.  Use /child:replace or /child:merge.

   at ThoughtWorks.CruiseControl.Core.Sourcecontrol.Vsts.LookForErrorReturns(ProcessResult pr)
   at ThoughtWorks.CruiseControl.Core.Sourcecontrol.Vsts.LabelSourceControl(IIntegrationResult result)
   at ThoughtWorks.CruiseControl.Core.Sourcecontrol.FilteredSourceControl.LabelSourceControl(IIntegrationResult result)
   at ThoughtWorks.CruiseControl.Core.IntegrationRunner.Build(IIntegrationResult result)
   at ThoughtWorks.CruiseControl.Core.IntegrationRunner.Integrate(IntegrationRequest request)


History

Updated by Ruben Willems over 2 years ago

Sounds more like a 'misuse' of labels, or a bad source control setup

see links below

https://groups.google.com/forum/#!msg/ccnet-user/AGeDZvPdBbw/hGkGatl8ZAkJ

http://stackoverflow.com/questions/9947645/understanding-label-limitations

if there are real reasons that this is needed, let us know

  • Status changed from New to Rejected

Updated by Aldus Monitor over 2 years ago

This might be correlated to the problem with CCNet not building in FIFO order (Bug #209). With filtered source control where a bigger framework owns some subprojects that is separately built this might cause problems if build order goes wrong? Could it also be caused by a temporary label name (something like CCnetUnverifiedXXXXXX) getting the same name in the filtered source control setup?

Poster MrK in this https://groups.google.com/forum/#!msg/ccnet-user/AGeDZvPdBbw/hGkGatl8ZAkJ is me.

Regards
Aldus

Updated by Aldus Monitor over 2 years ago

Oh I forgot: What both Paul and I have in common: There is only 1 build number per day and that does not change even if we have some minor issues during the daily build.

Normally it works fine. We can rebuild our framework repeatedly but I think that the issue comes with rebuild of a filtered sub project.

Regards
Aldus

Also available in: Atom PDF