ccnet.config custom path configuration not working (Bug #302)


Added by Ruben Willems over 3 years ago. Updated about 3 years ago.


Status:Closed Start date:09/01/2013
Priority:Normal Due date:
Assignee:- % Done:

0%

Category:Configuration Spent time: -
Target version:1.8.5
Affected version:1.8.0

Description

I have a CCNET 1.6 server properly configured and working. I had changed the service configuration to look for the projects configuration in D:\ccnet\config instead of the default C:\Program Files\CruiseControl.NET. No issues here.

I have been trying to test the upgrade of this server to the latest version (1.8.3). It seemed easy as the configurations appear to be extensively compatible. The only problem is that the new service will not launch. I checked with the console application (and the event viewer), and it seems that the server will always look for the projects configuration in the default path C:\Program Files\CruiseControl.NET, whatever the settings. I've tried to delete the default file, without success.
My configuration is as following: <add key="ccnet.config" value="D:\ccnet\config\ccnet.config"/>
I have checked in the source code, and it seems that this parameter is still intended to be used.


History

Updated by Mathieu Cartoixa over 3 years ago

This comment only to register as the original reporter of the bug (cf. https://groups.google.com/d/topic/ccnet-user/Od69_8LwKWQ/discussion), just in case you needed me ;-)
I have a VM where I could test any fixes.

Updated by Ruben Willems over 3 years ago

  • Target version set to 1.8.5

Updated by Ruben Willems over 3 years ago

seems to work here, C:\CCNet\Config\ccnet.config, and the service picked it up right away.

If you want to CCNet service to look in another folder, you must update ccservice.exe.config with the setting :
<add key="ccnet.config" value="C:\CCNet\Config\ccnet.config" />
which is in comment by default (around line 123)

If you want the console to work with an alternate config folder, you must add that as an argument. It is not a config setting in the console.
ccnet config=C:\CCNet\Config\ccnet.config

this worked for me.
Let me know if you still have problems

  • Status changed from New to Feedback

Updated by Mathieu Cartoixa over 3 years ago

My bad. I'm really sorry for the wasted time, but I was not aware that the same setting was ignored in the console configuration file. This lead me in a completely wrong direction.

As it happens, I had put the CCNET configuration on a mapped network drive (which allowed me to share the same files between my main computer and the VM I had setup to perform the tests). But the Local System user cannot see network drives, so CCNET could not find the configuration. Simple as that.

Thanks for your help.

Updated by Ruben Willems over 3 years ago

  • Status changed from Feedback to Closed

Updated by Chris . about 3 years ago

Rubens, you surprise me: we were using the console the same way as Matthieu (with ccnet.config location specificed in ccnet.exe.config) and unless I'm very tired today, it used to work fine. This was at v1.7 time.

By the way, there is a little typo in your command line (one dash missing): it's "ccnet -config=[...]" and not "ccnet config=[...]"

Also available in: Atom PDF