ArgumentNullException on multi source GetModifications() (Bug #303)


Added by T S almost 4 years ago. Updated almost 4 years ago.


Status:Closed Start date:09/02/2013
Priority:High Due date:
Assignee:Ruben Willems % Done:

0%

Category:Source Control Spent time: -
Target version:1.8.5
Affected version:1.8.4

Description

In function ThoughtWorks.CruiseControl.Remote.XmlConversionUtil.CanConvertXmlToObject() only XmlException is caught.
If the string message the StringReader is created with is null (like in this case) - BANG:

Error Message:
System.ArgumentNullException: Value cannot be null.
Parameter name: s
at System.IO.StringReader..ctor(String s)
at ThoughtWorks.CruiseControl.Remote.XmlConversionUtil.CanConvertXmlToObject(Type messageType, String message)
at ThoughtWorks.CruiseControl.Core.Sourcecontrol.MultiSourceControl.GetModifications(IIntegrationResult from, IIntegrationResult to)
at ThoughtWorks.CruiseControl.Core.Sourcecontrol.QuietPeriod.GetModifications(ISourceControl sourceControl, IIntegrationResult lastBuild, IIntegrationResult thisBuild)
at ThoughtWorks.CruiseControl.Core.IntegrationRunner.GetModifications(IIntegrationResult from, IIntegrationResult to)
at ThoughtWorks.CruiseControl.Core.IntegrationRunner.Integrate(IntegrationRequest request)

The affected project has the following configuration:
<project>
...
<svn>
<authCaching>None</authCaching>
<autoGetSource>True</autoGetSource>
<checkExternals>False</checkExternals>
<checkExternalsRecursive>True</checkExternalsRecursive>
<cleanCopy>False</cleanCopy>
<cleanUp>True</cleanUp>
<deleteObstructions>False</deleteObstructions>
<dynamicValues />
<executable>svn</executable>
<forceUpdate>False</forceUpdate>
<password>xxxxx</password>
<revert>False</revert>
<tagOnSuccess>False</tagOnSuccess>
<revisionNumbers>False</revisionNumbers>
<username>xxxxx</username>
<cb:trunkUrl />
<cb:workingDirectory />
</svn>
...
</project>

The integration result xml looks like:
</IntegrationResult>
...
<SourceControl name="SVN:LastRevision:http://foobar.com/svn/p1/trunk/" value="11363" />
<SourceControl name="SVN:LastRevision:" />
<SourceControl name="SVN:LastRevision:http://foobar.com/svn/p2/trunk/" />
</IntegrationResult>


History

Updated by Sergey Enns almost 4 years ago

I have the same error. Subversion v. 1.6.15.

Updated by T S almost 4 years ago

Additional info:
-SVN 1.7.9
-Migrated from CC.NET 1.8.3

Updated by Daniel Rose almost 4 years ago

Currently, the MultiSourceControl does not work together with svn. Duplicate of #304, where I wrote a patch.

Updated by Ruben Willems almost 4 years ago

  • Status changed from New to In Progress
  • Assignee set to Ruben Willems

Updated by Ruben Willems almost 4 years ago

  • Status changed from In Progress to Closed

Also available in: Atom PDF